とよぶ

歌いながらコード書いてます

Ruby, Railsインストール

OSはUbuntu12.04

# ruby
sudo apt-get install g++ libssl-dev zlib1g-dev libreadline-dev libxslt-dev libxml2-dev
wget http://pyyaml.org/download/libyaml/yaml-0.1.4.tar.gz
tar zxvf yaml-0.1.4.tar.gz
sudo mv yaml-0.1.4/ /usr/local/src/
cd /usr/local/src/yaml-0.1.4/
./configure -prefix=/usr/local
make
make test
make install
wget ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p385.tar.gz
tar zxvf ruby-1.9.3-p385.tar.gz
sudo mv ruby-1.9.3-p385/ /usr/local/src/
cd /usr/local/src/ruby-1.9.3-p385/
./configure -prefix=/usr/local
make
make test
make install
# rails
sudo gem install rdoc
sudo gem i rails


(追記)
なんかもっと楽そうにインストールできた。

$ sudo apt-get install apache2 curl git libmysqlclient-dev mysql-server nodejs
$ curl -L https://get.rvm.io | bash -s stable --ruby=1.9.3
### .bashrcにsource /home/toyo/.rvm/scripts/rvm追加
$ vim ~/.bashrc
$ sudo apt-get --no-install-recommends install bash curl git patch bzip2
$ sudo apt-get --no-install-recommends install build-essential openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev libgdbm-dev ncurses-dev automake libtool bison subversion pkg-config libffi-dev
$ rvm use 1.9.3 --default
$ gem install rails

うーん、rvmあたりがよくわかってないので時間があるときにrvmについて調べるかな。
当面は先にアプリ作って動かすこと考えたいw

広告を非表示にする